Author Topic: power steering issue with 4.3 swap  (Read 689 times)

0 Members and 1 Guest are viewing this topic.

Redfred018

  • Offline Rock Crawl'n
  • **
  • Turtle Points: -6
  • Male Posts: 38
  • Member since Nov '11
power steering issue with 4.3 swap
« on: Aug 27, 2015, 07:19:59 PM »
ok so got a 95 tbi 4.3 motor swap in my 81, i have it running and driving, my problem is my power steering is boiling up after only a few min of having the front hubs lock, so far i have added a larger cooler and its right in front of my fan so its getting air pulled thu it, i have changed the pump twice, double and triple check to make sure the lines are not plugged and switch the gear box  out still having the same issue. any ideas?!?!?!?! iam at a lost

Redfred018 [OP]

  • Offline Rock Crawl'n
  • **
  • Turtle Points: -6
  • Male Posts: 38
  • Member since Nov '11
Re: power steering issue with 4.3 swap
« Reply #1 on: Aug 28, 2015, 06:31:55 PM »
ok so after talking to a few guys on pirate, bout the fluid iam running which is dec/mec atf which has a boiling point around 500-600 f royal purple ez max power steering fluid has a boiling of 650-800 f so goin try that out and see what happens

spuds015

  • Offline Rock Master
  • ***
  • Turtle Points: 122
  • Male Posts: 208
  • Member since May '10
    • Buy me a beer
Re: power steering issue with 4.3 swap
« Reply #2 on: Aug 28, 2015, 06:57:52 PM »
Unlock your hubs
'81 pickup 22r, weber 32/36, 5 spd, 35's, welded 4.56's, f150 rear springs, Rears up front, TG dual adapter w/ 2.28's

 
 
 
 
 

Related Topics

1 Replies
1029 Views
Last post Oct 05, 2008, 12:32:53 PM
by Pat
13 Replies
2947 Views
Last post Aug 14, 2012, 10:38:59 PM
by Dingman.
9 Replies
2164 Views
Last post Feb 02, 2016, 05:48:40 PM
by KDC
14 Replies
4571 Views
Last post Jan 03, 2017, 10:29:38 PM
by ChadStich
4 Replies
189 Views
Last post Jul 24, 2019, 02:51:07 PM
by MrBooyay