Author Topic: 3.0 idled to 2000 rpm on startup and died when put into reverse.  (Read 785 times)

0 Members and 1 Guest are viewing this topic.

PeterPaul383

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 98
  • Male Posts: 36
  • Member since Oct '15
  • Crawling with Marlin
    • View Profile
Title says it all, anyone know what that could be? Thanks!

Snowtoy

  • Offline The 2K Group
  • ***
  • Turtle Points: 726
  • Male Posts: 2,388
  • Member since Sep '03
    • View Profile
Can you check for ecm codes?

Low idle could be the Mass Air Flow sensor.

Stall after starting could be the coolant temp sensor.

Will it fire up?
'90 black X-cab mod'd 3.0, 33's/4.88's, rear ARB, custom bumpers, sliders, safari rack, etc.
'91 Blue X-cab 22re, 35's/5.29's,Truetrac front, ARB rear, dual cases, and custom Safari flatbed, bumper, interior.
The money pit '87 Supra resto/mod

PeterPaul383 [OP]

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 98
  • Male Posts: 36
  • Member since Oct '15
  • Crawling with Marlin
    • View Profile
It started up and ran just fine the next day, I was just wondering what it could be. I just got it a week ago.

Dingman.

  • Offline Silver Turtle Award
  • *
  • Turtle Points: 960
  • Male Posts: 3,433
  • Member since Oct '08
    • View Profile
Not sure.  Is this a manual or automatic, not sure if that matters anyways.

I would check the intake and make sure it doesnt have a loose clamp or a hole anywhere in the boots to start off.  :dunno:

Snowtoy

  • Offline The 2K Group
  • ***
  • Turtle Points: 726
  • Male Posts: 2,388
  • Member since Sep '03
    • View Profile
Pull the codes when you can, may have a sensor starting to go.

If it was still cold when you went to leave, it could just be the truck, my 3.0 has always acted weird when I don't let it warm up for 5-10 minutes, and I have had it since it was new.
'90 black X-cab mod'd 3.0, 33's/4.88's, rear ARB, custom bumpers, sliders, safari rack, etc.
'91 Blue X-cab 22re, 35's/5.29's,Truetrac front, ARB rear, dual cases, and custom Safari flatbed, bumper, interior.
The money pit '87 Supra resto/mod

PeterPaul383 [OP]

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 98
  • Male Posts: 36
  • Member since Oct '15
  • Crawling with Marlin
    • View Profile
It's not throwing any codes. I figure I'll just try letting it warm up for longer. And it is an automatic.

 
 
 
 
 

Related Topics

78 Replies
17307 Views
Last post Mar 26, 2007, 11:04:13 PM
by 80crawleryota
13 Replies
1980 Views
Last post Oct 24, 2007, 06:50:11 PM
by lal357
4 Replies
1681 Views
Last post Oct 24, 2009, 11:50:55 PM
by joblo
12 Replies
1256 Views
Last post Apr 05, 2010, 09:56:21 AM
by Phazertwo
12 Replies
2188 Views
Last post Apr 27, 2010, 06:07:14 AM
by Kurlee Daddee