Author Topic: 89 22re sputtering when reved up (help!!!!)  (Read 1586 times)

0 Members and 1 Guest are viewing this topic.

NCK4L

  • Offline Crawler Guru
  • ****
  • Turtle Points: -2
  • Male Posts: 522
  • Member since Oct '08
89 22re sputtering when reved up (help!!!!)
« on: August 31, 2011, 10:23:27 PM »
this is my buddys 89 pickup with a 22re its his only rig so im tryin to get it back up some what quick he has no money for a real mechanic :gap:.
anyway about two weeks ago i put a new head on it as the old one was cracked and warpedd due to overheating. that went fine, truck ran great then over the weekend he said it started sputtering when he would really get on the gas like just before shifting gears. it has gotten a little worse over the past couple days he says. i posted some videos of what the truck was doing when i would rev it up hope it helps some. I had a 92 22re that was doing about the same exact thing a few years ago and turned out the exhaust was clogged . So far that is the  only thing i have checked on this truck and it is fine . Hopefully some of you guys will have  some suggestions on what could be wrong.  Just to sum it up truck idles fine but when you rev it makes a sputtering noise that sound like its coming from the throttle body and also loses power it doenst die though.





http://s659.photobucket.com/albums/uu318/NCK4L/dumb%20toyota/?action=view&current=photobucket-2884-1314851162367.mp4


http://s659.photobucket.com/albums/uu318/NCK4L/dumb%20toyota/?action=view&current=photobucket-2709-1314850686568.mp4
« Last Edit: August 31, 2011, 10:58:06 PM by NCK4L »

Joey88RUNR

  • Offline The 1K Club
  • *
  • Turtle Points: -23
  • Male Posts: 1,057
  • Member since Feb '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #1 on: August 31, 2011, 10:33:51 PM »
check the mass air flow sensor, make sure its not clogged or dirty.. there is a flapper valve in there that may be stuck.
SaS'd Dual ultimate crawler w/5.29s Aussie front/detriot Rear, 35's Mtr's with kevlar

Joey88RUNR

  • Offline The 1K Club
  • *
  • Turtle Points: -23
  • Male Posts: 1,057
  • Member since Feb '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #2 on: August 31, 2011, 10:37:55 PM »
and make sure there is no rips or tears in the intake after the air flow meter, which will be unmetered air causing lean issue. try moving it around while its running and see if idle changes
SaS'd Dual ultimate crawler w/5.29s Aussie front/detriot Rear, 35's Mtr's with kevlar

NCK4L [OP]

  • Offline Crawler Guru
  • ****
  • Turtle Points: -2
  • Male Posts: 522
  • Member since Oct '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #3 on: September 01, 2011, 07:50:26 AM »
im i think ive checked the whole intake tube and maf pretty good and didnt see anything out of the ordinary. As you can see in the second video when i slightly remove the tube from the intake it still does it and its really loud and sounds like its coming from the throttle body. by the way the truck isnt throwing any codes which leads me to believe its not a sensor of some sort.

crazykooter

  • Offline The 1K Club
  • *
  • Turtle Points: -370
  • Male Posts: 1,411
  • Member since Apr '09
  • Located in Byron, CA
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #4 on: September 01, 2011, 09:32:47 AM »
1st check that there isnt any vacuum leaks.   Its hard to tell on video but it sounds like it idles fine. 
Also the valves are pretty loose, but that isnt a bad thing on 22R/E's. 
I would check the tps since it idles fine and only happens under throttling.  I would like to hear it when you hold it rev'd.
Another thing,  if you hold it rev'd does it sound like it wants to back fire thru intake ?  The tps being bad will cause the computer to retard the timing and keep it from adjusting when at rpms.

NCK4L [OP]

  • Offline Crawler Guru
  • ****
  • Turtle Points: -2
  • Male Posts: 522
  • Member since Oct '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #5 on: September 01, 2011, 09:51:29 AM »
1st check that there isnt any vacuum leaks.   Its hard to tell on video but it sounds like it idles fine. 
Also the valves are pretty loose, but that isnt a bad thing on 22R/E's. 
I would check the tps since it idles fine and only happens under throttling.  I would like to hear it when you hold it rev'd.
Another thing,  if you hold it rev'd does it sound like it wants to back fire thru intake ?  The tps being bad will cause the computer to retard the timing and keep it from adjusting when at rpms.

ya it does seem to idle fine mabe a little rougher than normal. the valves do seem to be a little loose i set them when it was cold when i put a new head on a couple weeks ago. i dont think i have really held it reved maybe ill see what it does if i do that. i messed with the tps today it ran no different with it unplugged (idling or reved). maybe that could be causing it i think the truck has like 280,000 miles on it so its pretty worn. it also didnt run any different with the vaccum disconnected from the egr or the cold start injector unplugged

crazykooter

  • Offline The 1K Club
  • *
  • Turtle Points: -370
  • Male Posts: 1,411
  • Member since Apr '09
  • Located in Byron, CA
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #6 on: September 01, 2011, 07:42:42 PM »
If it idles and revs better with tps unhooked then its most likely your tps is bad.  It doesnt take much to throw them off.  If you get it wet or banged a little its gonna kill it.
You can get used ones but a new tps is around 60 bucks at kragen.

NCK4L [OP]

  • Offline Crawler Guru
  • ****
  • Turtle Points: -2
  • Male Posts: 522
  • Member since Oct '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #7 on: September 01, 2011, 08:28:05 PM »
well i guess i made some new findings today. something i probably should have figured out a lot sooner. when i unplug the spark plug from #3 cylinder it doesnt chage the way it runs at all. it seems to have spark and it has 160psi of pressure. im thinking it might be fuel now but only on #3 cylinder so im not sure what might cause that i fiddled around with the wires a bit but it didnt seem to do anything. Not sure/ if for some reason that injector is not working or what?

b_sherwood3

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 0
  • Male Posts: 31
  • Member since Sep '11
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #8 on: September 15, 2011, 02:33:49 AM »
Is there any smoke coming out of the tail pipe?  I would let it idle for about 20minutes then readjust the valves, check to see that nothing has come loose.  I don't think its a vacume leak because normally when you have a vacumm leak the idle usually smooths out around 1500rpm, but to be sure you could spray some carb fluid around the intake and see if it revs up any.   Also check the timing when you take off the valve cover and adjust the valves, your chain could be one sproket off, make sure TDC lines up.   

toyotagirl7

  • Offline Dusty Trails
  • *
  • Turtle Points: 0
  • Female Posts: 7
  • Member since May '14
  • Stealing hearts & breaking parts
    • Buy me a beer
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #9 on: May 03, 2014, 11:30:55 PM »
Were you able to figure out what was wrong? My toyota is doing the same thing. If the gas pedal is to the floor it just sputters & the rpms wont go up. Ive replaced the spark plugs & wires, fuel filter, ignition coil & we dis a compression check on the cylinders & they were all fine. Could it be the fuel injectors? Or distributor? My cat was also glowing red, so we hollowed it out because I thought it was clogged. That didnt help. Memorial Day is coming & I need my rig running! :(

Dingman.

  • Offline The 2.5K Group
  • ****
  • Turtle Points: -47
  • Male Posts: 2,944
  • Member since Oct '08
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #10 on: May 04, 2014, 03:27:03 AM »
Were you able to figure out what was wrong? My toyota is doing the same thing. If the gas pedal is to the floor it just sputters & the rpms wont go up. Ive replaced the spark plugs & wires, fuel filter, ignition coil & we dis a compression check on the cylinders & they were all fine. Could it be the fuel injectors? Or distributor? My cat was also glowing red, so we hollowed it out because I thought it was clogged. That didnt help. Memorial Day is coming & I need my rig running! :(

Check your other thread, i made a couple suggestions in there also.
I wonder if your timing may have jumped a tooth


tgmaul88

  • Offline 4WD Legend
  • *****
  • Turtle Points: 20
  • Male Posts: 960
  • Member since Feb '12
  • Im still alive
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #11 on: May 04, 2014, 09:07:31 AM »
I would look at the timing, get crank pully on Tdc.  check cam mark and dizz gear for proper placement. 

chris514scott

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 0
  • Posts: 14
  • Member since Dec '12
  • Crawling with Marlin
Re: 89 22re sputtering when reved up (help!!!!)
« Reply #12 on: May 23, 2014, 11:05:47 AM »
I had a similar problem and it was the fuel pressure reg.

 
 
 
 
 

Related Topics

  Subject / Started by Replies Last post
6 Replies
856 Views
Last post May 04, 2014, 09:02:51 PM
by toyotagirl7
18 Replies
1132 Views
Last post December 06, 2008, 01:51:51 PM
by bossnote
16 Replies
1417 Views
Last post April 10, 2010, 05:36:25 PM
by exxon
10 Replies
4282 Views
Last post August 31, 2011, 12:22:17 PM
by BHT12
12 Replies
410 Views
Last post May 25, 2014, 08:03:43 PM
by Chuyota