Author Topic: 89 22re fuel problem Help Me  (Read 780 times)

0 Members and 1 Guest are viewing this topic.

hman1991

  • Offline Rock Crawl'n
  • **
  • Turtle Points: 0
  • Male Posts: 37
  • Member since Oct '06
89 22re fuel problem Help Me
« on: Aug 21, 2008, 07:31:46 PM »
my pickup is running rough and i don't know why it misses at idle. right when you first start it iw will want to die after like 5 seconds. sometimes it does and needs restarted. i just need some ideas. i took the injectors out and checked the flow. they seemed to flow good. now i am throwing codes 25 and 26 i think it is the rich code and the lean code. also throwing o2 code. it is missing o2 but always has and ran fine b4. now i can smell it running way rich. i messed with the dizzy timing and it ran gr8 for a day and then gradually got worse. it cruises fine at like 55. its just the starting off. if i run it wide open to take off it is a little better. i am stumped though. any ideas would help btw i replaced cap, rotor, wires, plugs, air filter, and fuel filter. also it seems like the injectors r noisy. i cannot find injectors local to try that r obd1.

 
 
 
 
 

Related Topics

10 Replies
6750 Views
Last post Mar 31, 2005, 07:34:15 PM
by alwayzbroken
6 Replies
1869 Views
Last post Jun 24, 2007, 09:41:07 PM
by speedemon
2 Replies
724 Views
Last post May 13, 2007, 06:44:35 PM
by usmcab35
11 Replies
10872 Views
Last post Mar 24, 2009, 02:32:13 PM
by unclejpl4x4
2 Replies
570 Views
Last post Mar 06, 2016, 02:47:00 AM
by skid